Page 1 of 1

Cross-site lookup fields not accessible in MS Flow

Posted: 04 Jun 2020
by sandernelen
Dear

I searched trough a lot of topics regarding this issue. I have multiple lookup fields but I can't access them using MS Flow.
I just want to store their values in to a variable, but the value just isn't accessible.
The names of the columns are: 'School' and 'Vestiging' (our SharePoint Online has dutch language, Opzoeken is lookup)
4.PNG
4.PNG (51.82 KiB) Viewed 9356 times
In flow I tried accessing them with an expression:
4.PNG
4.PNG (51.82 KiB) Viewed 9356 times
And also the columns are not appearing in the search function:
4.PNG
4.PNG (51.82 KiB) Viewed 9356 times
While the normal lookup and standard fields are appearing:
4.PNG
4.PNG (51.82 KiB) Viewed 9356 times
The return of the variable just gives an empty string when running the flow:

Re: Cross-site lookup fields not accessible in MS Flow

Posted: 04 Jun 2020
by mnikitina
Hello sandernelen,

Please try to use this expression in the flow:

Code: Select all

@{triggerBody()?['Lookup']?['Value']}
Where Lookup is the internal name of the field. You can find the internal name of the field either in Forms Designer or in the List Settings >> Columns Settings >> Page URL.
Capture.PNG
Capture.PNG (142.49 KiB) Viewed 9355 times

Re: Cross-site lookup fields not accessible in MS Flow

Posted: 08 Jun 2020
by sandernelen
Dear mnikitina

Something went wrong with my post, the suggestion you gave I already found in another post and does not work for me:
Column name in URL:
URL.PNG
URL.PNG (92 KiB) Viewed 9344 times
Declare variable with field as string:
varstring.PNG
varstring.PNG (10.83 KiB) Viewed 9344 times
Output is empty when running flow:
output.PNG
output.PNG (7.85 KiB) Viewed 9344 times
I also tried just to 'compose' the field in flow, still can't get the value... Any other suggestions?

Thanks in advance,

Sander

Re: Cross-site lookup fields not accessible in MS Flow

Posted: 10 Jun 2020
by mnikitina
Hello sandernelen,

Have you selected a specific View for the field Limit columns by View?
4d376324741a573cd3b1a42bdc73169372281ede.png
4d376324741a573cd3b1a42bdc73169372281ede.png (6.79 KiB) Viewed 9342 times
If yes, please make sure the view you’ve selected contains all columns. Do you see the lookup column in the dynamic content?

Also please try to create a new flow and check if you can see the lookup column in the dynamic content.

If that doesn't help, please contact Microsoft support for help as this issue is not related to cross-site lookup columns.