Page 1 of 2

[BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 19 Jul 2020
by PSB
In continue this topics:
viewtopic.php?f=1&t=3269&p=8947&hilit=e ... mply#p8947
viewtopic.php?f=1&t=3544&hilit=edit+form+emply

After update SP19 on July 2020 CU - i got the same problem.
On edit form, Lookup Fields - blank.
If change control template on "default" - all ok.

____________
SP - 19 on premise
FDC: 3.1.4
Cross-site Lookup 1.4.4

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 19 Jul 2020
by Nikita Kurguzov
Dear PSB,
There was an issue after SharePoint update, so we've published a fix some time ago. Please, download and install the latest version of Forms Designer for SP 2013/16/19. Version number will NOT change (as the fix is very minor) and file size is the same as before, but the update is included in the new file.

Start the installer and select Repair option. Then, completely clear the browser's cache. Might also need to update .NET on the server.

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 21 Jul 2020
by bua
We have the same problem after SP updates last week. We tried to install the latest version, but as we have Forms Designer Client version 3.0.8 now get an error: "The version of Forms Designer installed on the server is not compatible with the current client version".
Cross-site Lookup version 1.4.3
Should we update versions? Where to download them?

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 22 Jul 2020
by mnikitina
Hello bua,

You need to download and install the latest version of the client application. Find the Forms Designer icon in Customize List section in the ribbon, click it and download the installer.
client-application[1].png
client-application[1].png (28.37 KiB) Viewed 8179 times

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 22 Jul 2020
by PSB
Thanks, bug is fixed!

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 21 Sep 2020
by UDRO
Hello,

I have the same Problem.

We use
SP 2013 on premise
FDC 3.1.4 (Desktop-App)
Cross-site Lookup 1.4.3

When I choose cross-site-lookup-template in forms-designer the field is empty in Edit-mode. When I use another template the filtered lookup does not work. All the values from the target-list are shown.

Do you have any idea, what we can do About this?

Thanks for your answer.

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 21 Sep 2020
by UDRO
Hello,

I have the same Problem.

We use
SP 2013 on premise
FDC 3.1.4 (Desktop-App)
Cross-site Lookup 1.4.3

When I choose cross-site-lookup-template in forms-designer the field is empty in Edit-mode. When I use another template the filtered lookup does not work. All the values from the target-list are shown.

Do you have any idea, what we can do About this?

Thanks for your answer.

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 22 Sep 2020
by mnikitina
Hello Udro,

You need to install the latest version of Forms Designer for SP 2013/16/19. Version number will NOT change (as the fix is very minor) and file size is the same as before, but the update is included in the new file.

Start the installer and select Repair option. Then, completely clear the browser's cache. Might also need to update .NET on the server.

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 24 Sep 2020
by UDRO
Hello,

ok. Seems like our server-admins installed version 3.1.4, which they downloaded before the bug was fixed. :oops:

With the latest version the problems are solved.

Re: [BUG] Plumsail Lookup Fields are blank on Edit form

Posted: 27 Sep 2020
by Lubo
Hello, We have same issue,

but when I tried install latest version of Forms Designer mentioned by mnikitina, we got another issue, where we were not able to open pages where were added form on the page with webpart "Insert New form". Webpages got Runtime error. Also all forms ( New ) we were not able to open.

We use:

Sharepoint 2013 Foundation with latest CU September 2020
SPForm v3.1.4 from May/2020