Page 1 of 2

Plumsail lookup fields are blank on edit

Posted: 04 May 2020
by Marshall
Hello

We have just stared seeing the problem reported here - viewtopic.php?f=1&t=3269&p=8949&hilit=c ... lank#p8949.

If you edit a record using an SP Form, Plumsail cross site lookup fields containing values are blanked. It works ok if you have a cross site lookup field when you are not using a spform. The problem is occurring in Chrome, IE and Firefox.

Has this been resolved yet or is there a fix?

Many thanks
Marshall

Re: Plumsail lookup fields are blank on edit

Posted: 04 May 2020
by mnikitina
Hello Marshall,

Yes, we've published the fix that resolved this.

Are you using SharePoint Online?

Do you see any errors in the console(F12) when Edit form is loaded? Do you see the lookup values in the list view?

Re: Plumsail lookup fields are blank on edit

Posted: 05 May 2020
by Marshall
Hi Mnikitina

We are using SharePoint 2013. There are no errors in the console and I can see the lookup values in list view, not edit view. I can also see the lookup value in edit view if I make the field readonly in sp forms.

Regards
Marshall

Re: Plumsail lookup fields are blank on edit

Posted: 05 May 2020
by Marshall
Hi Mnikitina

Is there any update on this? It's getting very urgent. I have a number of forms and workflows including some external facing forms that are halted because of the problem.

We are GMT+8.

Many thanks
Marshall

Re: Plumsail lookup fields are blank on edit

Posted: 05 May 2020
by mnikitina
Hello Marshall,

What version of the Forms Designer are you using? You can find it in the lower right corner of the designer.

Re: Plumsail lookup fields are blank on edit

Posted: 05 May 2020
by Marshall
Forms Designer 3.1.4

Re: Plumsail lookup fields are blank on edit

Posted: 06 May 2020
by Marshall
Hello again

I have just found out that the problem only happens if the field uses the template Cross-site Lookup. If you select template default or SP 2010, the field is populated.

This is only a workaround as when the field allows multiple selections the field display takes up too much space with two columns and the add/remove buttons.

Something has changed, it was working up until last week.

Regards
Marshall

Re: Plumsail lookup fields are blank on edit

Posted: 06 May 2020
by mnikitina
Hello Marshall,

Thank you for these details.

Could you please also check what version of the Cross-Site lookup you are using. You can find it on the Lookup Manager page.
CSL version.png
CSL version.png (41.42 KiB) Viewed 4169 times

Re: Plumsail lookup fields are blank on edit

Posted: 07 May 2020
by Marshall
Cross-site lookup 1.4.4

Regards
Marshall

Re: Plumsail lookup fields are blank on edit

Posted: 07 May 2020
by mnikitina
Hello Marshall,

Please download the latest version of Cross-site Lookup and Forms Designer from our web site here and re-deploy the solution. Note that even though it says Trial since you already have the license, it will be a full version for you.

You can find the installation instructions here.

Once this is done, you need to re-save forms. Please check if the issue with the cross-site lookup fields persists and let me know.