Page 1 of 2

Related Items are not showing on New form

Posted: 24 Jun 2021
by Katy
Hi there,
I have a strange issue recently: related items are not visible on the New form. I am doing everything the same according to the article, and the parent ID is populating correctly, but the items are not visible on the form. When i open Edit all the items are there. But this is very confusing to the users: they lose track of what they've already added to the list. Can you please let me know if anything changed and i need to do something else?
My settings are the same as in the article: data source is set to show new items only and quick edit to None.

Re: Related Items are not showing on New form

Posted: 25 Jun 2021
by mnikitina
Hello Katy,

What SharePoint version are you using?

Is that a new form? Are experience the same issue on other new forms with related items?

Please share the screenshot of errors from the browser console (F12).

Re: Related Items are not showing on New form

Posted: 28 Jun 2021
by Katy
Hi, sorry I was away.
I am using SP 2013. The issue happens only on the New Form and I am not getting any visible errors, although I do notice that after I save the related item the whole page with the main item reloads and the newly created item is not showing. Here is how the console looks:
before I save a new related item:
newform1.png
newform1.png (60 KiB) Viewed 4711 times
after I save a new item:
newform2.png
newform2.png (78.06 KiB) Viewed 4711 times
Again, the related items are saved fine, as expected, they are just not visible on the New form (the items are placed/added in regular mode)

Re: Related Items are not showing on New form

Posted: 29 Jun 2021
by mnikitina
Hello Katy,

Please export the form and share it, I'll check the setting and try to reproduce the issue on my tenant.

Re: Related Items are not showing on New form

Posted: 29 Jun 2021
by Katy
mnikitina wrote:
29 Jun 2021
Hello Katy,

Please export the form and share it, I'll check the setting and try to reproduce the issue on my tenant.
Here is the form, thank you so much for your help!

Re: Related Items are not showing on New form

Posted: 30 Jun 2021
by Katy
So I've been digging through the forum and so this thread, and i am sure that the issue is that the main page is reloading after I save a new related item. But that is not the expected behaviour, why is this happening? What might cause this reload?
just an update: i created the simplest form with related items where the only script is populating ID - still doing a refresh of the main form when i save the related item and doesn't show it on the main form :-(

Re: Related Items are not showing on New form

Posted: 01 Jul 2021
by mnikitina
Hello Katy,

Thank you for the exported form. I couldn't reproduce the issue on my tenant.

The refresh is expected, but that should not affect the related items.

Have you tested the new form with the same child list? Do you have any workflows in a child list?

Re: Related Items are not showing on New form

Posted: 01 Jul 2021
by Katy
mnikitina wrote:
01 Jul 2021
Have you tested the new form with the same child list? Do you have any workflows in a child list?
No, I created a brand new form on the site under a different site collection even. There are no workflows on any of the lists.

Re: Related Items are not showing on New form

Posted: 02 Jul 2021
by mnikitina
Katy,

Could you please export the new form of the child list and share it too. Thank you!

Re: Related Items are not showing on New form

Posted: 05 Jul 2021
by Katy
mnikitina wrote:
02 Jul 2021
Katy,

Could you please export the new form of the child list and share it too. Thank you!
Sure, here is the new form for the related list.