forms no longer working - Major Problem

Discussions about Forms Designer for SharePoint 2013 / 2016 and Office 365.
Post Reply
User avatar
Roo
Posts: 107
Joined: Tue Oct 24, 2017

10 Sep 2020

I've recently put in some edit forms onto a online site (2 variations per edit form. 1 default and one for a SPGroup)

Once I applied these settings I got an error:

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Microsoft SharePoint Foundation-compatible HTML editor such as Microsoft SharePoint Designer. If the problem persists, contact your Web server administrator.


Correlation ID:7f99789f-60d1-2000-556d-c1cc3f25f6aa

TypeError: r is not a function
TypeError: r is not a function

TypeError: r is not a function
TypeError: r is not a function

TypeError: r is not a function
TypeError: r is not a function

TypeError: r is not a function
TypeError: r is not a function

TypeError: r is not a function
TypeError: r is not a function


Now when I go into the edit form and try and remove the redirection webpart the browser just loops and I can no longer access the form. This is a major Issue as I need this working,

User avatar
Roo
Posts: 107
Joined: Tue Oct 24, 2017

10 Sep 2020

I managed to resolve this, but had to remove the SP Forms in Sharepoint Designer and reload them. It didn't seem to like the webpart to redirect??

User avatar
mnikitina
Posts: 263
Joined: Wed Jun 05, 2019

11 Sep 2020

Hello Roo,

Is this a big complex form with many fields?

As this is a well-known problem, please refer to this article for more information:
https://spform.com/uncategorized/handli ... office-365

User avatar
Roo
Posts: 107
Joined: Tue Oct 24, 2017

11 Sep 2020

I guess it is quite complex, with up to 6 child forms within it.

I'm going to avoid using this and try and use the group security within javascript

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 2 guests